PBC:VisualEditor

From Porn Base Central, the free encyclopedia of gay porn
(Redirected from PBC:VE)
Jump to navigation Jump to search
PBC VisualEditor
Shortcut:

VisualEditor gives you the ability to edit without needing to learn wikitext markup, as is required by the default wikitext editor. Unlike that editor, VisualEditor will display the text being edited almost as if it were already saved. This guide gives illustrated, step-by-step instructions on the editor's features, although it may occasionally lag behind the release of new ones.

Be aware that VisualEditor is still in development and thus has known limitations and bugs. For example, particularly for large pages, VisualEditor can be slower than wikitext. While VisualEditor remains in development, you should review your changes to ensure that the edits you make are those you intended.

Availability

VisualEditor is available on the following types of pages (namespaces):

  • Article ("mainspace")
  • User (not Social Profile)
  • Category
  • Help
  • File (but not with files, or other pages)

First step: enabling or disabling VisualEditor

VisualEditor available for editing by default. You'll need a VisualEditor-supported browser; most are. You can also disable VE by changing your preferences.

Opening VisualEditor

To edit a page using VisualEditor, click on the "Edit" tab at the top of the page.

It can take a few seconds for the page to open for editing, and longer if the page is very long.

Clicking on the "Edit source" tab will open the classic wikitext source editor.

PBCVisualEditor edit tab-en.png

You can also open VisualEditor by clicking on the "edit" link on each section.
PBCVisualEditor Section edit links-en.png

Getting started: the VisualEditor toolbar

Screenshot of the VisualEditor toolbar
The VisualEditor toolbar appears at the top of the screen when you begin editing. It includes some familiar icons:

PBCVisualEditor Toolbar Undo-Redo.png
Undo and Redo the changes you have made.

PBCVisualEditor Toolbar Headings-en.png
Headings pull-down menu: allows you to change how the paragraph is formatted. To change the style of a paragraph, put your cursor in the paragraph and select an item in this menu (you don't have to highlight any text). Section titles are formatted "Heading", and subsections are "Heading 2", "Heading 3", and so on. The normal format for text is "Paragraph".

PBCVisualEditor Toolbar Formatting-en.png

Formatting: Clicking the "A" opens a menu.

  • The "Bold" item (B) bolds the selected text.
  • The "Italic" item (I) italicizes the selected text.
  • The "Superscript" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "Subscript" item (x2) causes the selected text to appear smaller than surrounding text and slightly lower than the surrounding text.
  • The "Strikethrough" item (S) adds a solid bar through the selected text.
  • The "Computer code" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Underline" item (U) adds a solid line beneath the selected text.
  • The "Language" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Remove", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


PBCVisualEditor Toolbar Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

PBCVisualEditor Cite Pulldown.png
Cite menu: The "Cite" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to "Basic" reference formatting and the ability to "Re-use" citations, using this menu. This menu also gives you quick access to local citation templates.

PBCVisualEditor citoid Cite button.png
Cite button: If the citoid service is enabled, then you will see a "Cite" button instead of a Cite menu.

The citoid service tries to fill out citation templates automatically.


PBCVisualEditor Toolbar Lists and Indentation-en.png
Lists and indentation: The first two items allow you to format text as either a "Bullet list" or a "Numbered list". The last two items allow you to decrease or increase the indentation level of list items.

PBCVisualEditor Insert Menu-en.png
Insert: The "Insert" menu may be different on some projects. Below is a list of all options that may appear.
  • The "Media" icon (a picture of mountains) opens the media dialog.
  • The "Template" icon (a puzzle piece) allows you to edit templates.
  • The "Comment" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode and are then indicated by an exclamation mark icon.
  • The table item allows you to insert a table.
  • The "⧼visualeditor-mwgalleryinspector-title⧽" icon (a set of photos) allows you to insert a gallery to the page.
  • The "Formula" icon (Σ) opens the formula inserter dialog.
  • The "Hieroglyphs" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "References List" icon (three books) opens a dialog in which you can specify where will references be displayed to the reader. Usually this only needs to be done once on every page.

Special character insertion: The "Special character" (Ω) icon on the "Insert" menu, when clicked, displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (This list may be customized locally.)
PBCVisualEditor Toolbar SpecialCharacters-en.png

PBCVisualEditor More Settings-en.png
The Page options menu is to the left of the Save page button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "Language" item, the list of articles on the same subject that are in other languages. You can also switch (one-way only) from VisualEditor to the classic wikitext source editor without losing the editing work you've done.